Datacenter internet connection offline

Incident Report for Plant Ranger

Postmortem

At 4:19am PDT, Down alerts for applications hosted at the datacenter began firing. It was quickly determined the datacenter lost internet. A few hours later the connection was restored. While the connection was offline all the sensors were tagged as offline and notifications where queue up. When connectivity was restored the backlog of notifications were sent.

We have take steps to track when data is not longer being injected and preventing offline notifications from being sent. All sensor data sent during the outage was lost. We are considering buffering unsent data on the bridge to avoid dropping data during future outages.

Posted Aug 22, 2026 - 19:09 UTC

Resolved

From 4:15 to 8:23 PDT on August 18th our datacenter's ISP had an outage stopping all traffic. The ISP resolved the issue and operation resumed without aid.
Posted Aug 18, 2026 - 11:00 UTC